Tracker-miners-2.3.2

Introduction to Tracker-miners

The Tracker-miners package contains a set of data extractors for Tracker.

This package is known to build and work properly using an LFS-9.1 platform.

Package Information

Tracker-miners Dependencies

Required

gst-plugins-base-1.16.2, Tracker-2.3.2, Exempi-2.5.1, and gexiv2-0.12.0

Recommended

Optional

CMake-3.17.0, DConf-0.34.0, libgsf-1.14.47, libseccomp-2.4.3, taglib-1.11.1, totem-pl-parser-3.26.5, UPower-0.99.11, libcue, libosinfo, and gupnp

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/tracker-miners

Installation of Tracker-miners

Install Tracker-miners by running the following commands:

mkdir build &&
cd    build &&

meson --prefix=/usr .. &&
ninja

To test the results, as the root user, issue: ninja test. Eight tests, test-image-1, 300-miner-basic-ops, 310-fts-basic, 310-fts-basic, 311-fts-file-operations, 401-extractor-flac-cuesheet, 500-writeback-images, 501-writeback-image-details, and 502-writeback-audio are known to fail due to internal test suite problems.

Now, as the root user:

ninja install

Command Explanations

-Dminer_rss=false: Use this option if you have not installed the recommended dependency libgrss.

Contents

Installed Programs: None
Installed Libraries: libtracker-extract.so, and several modules under /usr/lib/tracker-miners-2.0.
Installed Directories: /usr/lib/tracker-miners-2.0 and /usr/share/tracker-miners

Last updated on 2020-02-26 20:21:07 -0600